Skip to main content

Known DHL Error Messages

In this article, you'll find some known error messages related to DHL shipping and their solutions. In all cases: if the problem persists after following the steps described, please contact our Support.

DHL Error Message: Unknown group profile

If the following error message appears, it's because the user in the business customer portal isn't assigned the correct profile.

Error
Die Sendung konnte aufgrund von Fehlern nicht erstellt werden: Die DHL BCP API hat mit einem Fehler geantwortet: Unknown group profile.

To fix the problem, log in to the DHL Business Customer Portal. Under Paket & Waren → Versenden → Einstellungen → Nutzergruppen, you can assign the STANDARD_GRUPPENPROFIL to the user.

DHL Fehler1.png

DHL Error Message: Invalid printer settings

The following error message indicates a problem with the printer settings.

Error
Die Sendung konnte aufgrund von Fehlern nicht erstellt werden: Die DHL BCP API hat mit einem Fehler geantwortet: invalid printer settings - please adjust your printer settings in the DHL business customer portal "Sending > Basic Settings > General" and save them in any case with occupied user

To fix the problem, navigate in the DHL Business Customer Portal to Paket & Waren → Versenden → Einstellungen → Allgemeine Einstellungen and disable the local printer settings there.

DHL Fehler2.png

DHL Error Message: DHL Authorisation Server

If the following error message appears when creating shipping or return labels, it may be because two-factor authentication (2FA) is enabled for the DHL user being used.

Error
Die Sendung konnte aufgrund von Fehlern nicht erstellt werden: Die DHL Parcel API hat mit einem Fehler geantwortet: DHL Authorisation Server: Access denied, direct grant with security profile enhanced not allowed.

image.png

Cause

The DHL API doesn't support authentication with two-factor authentication (2FA) enabled. If 2FA is active in the DHL Business Customer Portal, Pickware can't establish a connection to the API.

Solution

  1. Use a system user
    Create a system user in the DHL Business Customer Portal that's used exclusively for API access. For such users, 2FA is usually not available, which ensures a stable connection.

  2. Alternative: disable 2FA
    If a separate system user can't be created, disable 2FA for the currently used user.

  3. Check credentials
    Then re-enter the credentials of the user being used in the DHL configuration of your Pickware Admin and test the connection.

DHL Error Message: Unexpected client error

The following error message indicates that the terms of use in the DHL customer account have changed and need to be accepted again.

Error message: There occurred an unexpected error: Client error: `GET https://geschaeftskunden.dhl.de/customeradministration/api/v1/user` resulted in a `403 Forbidden` response

To fix this, log in to the DHL Business Customer Portal, click your username in the top right, and then click Manage users (Benutzer verwalten). A pop-up window will then open where you can accept the new terms of use.

DHL Fehler3.png

DHL Error Message: Sender address is incomplete

The following error message indicates that the sender address is incomplete.

The sender address is missing the following property: Name, company or address addition.

In this case, go to Settings → Extensions → Shipping Labels General in your Pickware Admin and enter the missing data there. You can find more information on the available settings here.

DHL Error Message: Billing number is not available

The following error message indicates problems with the stored billing number.

Hard validation error occured. Die ausgewählte Abrechnungsnummer steht nicht zur Verfügung

In this case, the number stored under Settings → Extensions → Shipping Labels DHL → Contract Information doesn't match the number in the DHL Business Customer Portal. You can find the correct numbers in the DHL Business Customer Portal in the user menu in the top right under Vertragsdaten. The last two digits of the billing numbers are relevant.

DHL_GKP_Vertragsdaten.png

DHL Error Message: Error creating shipping or return labels

If an error message appears when creating shipping or return labels, this may be because the contract data can't be correctly retrieved from the DHL Business Customer Portal. First, check in the Pickware Admin under Extensions → Settings → Shipping Labels DHL using the Retrieve Contract Data button whether retrieving the contract data works at all.

If your contract data can be retrieved correctly and you still can't create shipping labels, please contact Support.

If retrieving the contract data fails, proceed as follows:

  1. Log in to the DHL Business Customer Portal and navigate to Manage users (Benutzer verwalten). Here you may need to confirm new terms of use.

  2. Open the extension settings again under Extensions → Settings → Shipping Labels DHL and click Retrieve Contract Data at the top.

    Vertragsdaten abrufen.png

  3. Check whether creating shipping labels works again.

DHL Error Message: Authentication failed: User not found or password invalid

If this error message occurs when creating shipping or return labels, there can be two causes:

Option 1: Login credentials (username, password) weren't entered correctly in the DHL configuration

Note that the username must be entered exactly (including upper and lower case) as it's listed in the DHL Business Customer Portal under Manage users (Benutzer verwalten).

To check how your username is stored at DHL, proceed as follows:

  1. Click your username in the top right and then click Manage users (Benutzer verwalten).

  2. Your usernames are displayed in the table:

DHL Fehler4.png

The DHL shipping settings can also be configured at the Sales Channel level if needed. If the error message is still displayed despite entering the correct credentials, also check the settings for the individual Sales Channels.

DHL_Verkaufskanal.png

Usually, the settings made under All Sales Channels are inherited by the other Sales Channels. You can recognize this by the icon in front of the field name when you've selected a Sales Channel. However, it's also possible to exclude individual fields from this by clicking the icon. Here you can see an example of a non-inherited field (username) and an inherited field (password).

DHL_Einstellung vererben.png

Option 2: The selected DHL product isn't available in combination with your DHL contract.

To use the products DHL Retoure Online and DHL Retoure International, you need:

  • a valid business customer contract with DHL Paket GmbH for the products DHL Retoure Online and/or DHL Retoure International

  • access to the Post & DHL Business Customer Portal with permission for the Retoure function

A contract for DHL Retoure Selbstzahler isn't sufficient in this case! Please contact your DHL representative to adjust your contract.

DHL Error Message: Create label to [name], parcel 1: Hard validation error occured. Das angegebene Produkt ist für das Land nicht verfügbar

This error message appears if you've selected the DHL product DHL Paket for a shipment outside Germany. Select DHL Paket International instead and create the label again.

DHL Error Message: Die Kommunikation mit der DHL BCP API ist nicht möglich. Error: Unauthorized.

This error message appears if you've selected the testing web service in the DHL configuration but haven't entered the correct credentials. In this case, you need to enter the API key and API secret of your DHL developer portal account instead of your regular credentials.

DHL Error Message: Der Parameter name muss zwischen 1 und 50 Zeichen lang sein.

This error message appears if one of the fields name1, name2, or name3 is longer than 50 characters. The name fields are filled in automatically as follows:

If a company is specified:

  • name1 = company + department

  • name2 = first name + last name

  • name3 = address addition

If no company is specified:

  • name1 = first name + last name

  • name2 = address addition

  • name3 = [remains empty]

Check whether, for example, the combination of company and department, or first name and last name, might be too long, and adjust the entries accordingly. You can find a tool for counting characters, for example, here.

DHL Error Message: Email address exceeds the permitted field length

This error message appears if the email address stored in the order is longer than the limit permitted by DHL for this field. In this case, DHL rejects the creation of the shipping label with the following error message.
The DHL Express API could not process the request:

#/shipmentNotification/0/receiverId: expected maxLength: 50, actual: X

This occurs particularly often with orders from marketplaces such as Amazon, since the buyer email addresses transmitted there (e.g. …@marketplace.amazon.com.de) can be very long. In this case, shorten the email address in the affected order and create the shipping label again afterward. If the full email address is required, the label can alternatively be created directly in the DHL Express Portal.

DHL Error Message: The DHL Parcel API responded with an error: Sorry, this recipient is not available

Pickware only supports DHL Retoure Online. The DHL Retoure Selbstzahler variant is not compatible and therefore can't be used for automatically creating return labels. If DHL Retoure Selbstzahler is nevertheless stored for a shipping method or product, this leads to this error message when creating a shipping label. In this case, make sure that the correct return type DHL Retoure Online is used.

DHL Rounding Error

If the weight of your packages isn't rounded correctly, this may be due to an incorrect setting in your PHP configuration. Check in your php.ini whether the value for serialize_precision is set to -1, and if not, adjust the value accordingly. You can find more information, for example, here.

Shipping labels are incorrectly declared as PREMIUM

If your shipping labels are created as a Premium Label despite the Premium function being disabled, this is because most EU countries don't offer Economy products, in which case DHL automatically activates the Premium function.

Großkundenempfänger konnte nicht gefunden werden

This error message can appear if the option Only create label if address is route-codable (leitcodierbar) is enabled when creating a shipping label.

leitcodierbar.png

When route codability is enabled, DHL checks whether the combination of street and postal code is uniquely stored in the system. However, some large customers, such as universities or government agencies, use different postal codes for postal and street addresses. As a result, the address may not be correctly matched by the DHL system.

Example

A university in Berlin uses 10099 Berlin as its general postal address, but also 10117 Berlin for street addresses. In this case, label creation can only be completed successfully with the correct street postal code (10117 Berlin). If 10099 is used, the error message appears.

Solution

Use the matching street postal code, or simply disable the option Only create label if address is route-codable (leitcodierbar) to create the shipping label anyway.

Did this answer your question?